What’s Vulnerable › Vulnerabilities
CVE-2026-6270: @fastify/middie vulnerable to middleware authentication bypass in child plugin scopes
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-04-16 · updated 2026-06-17
- Weakness: CWE-436
Description
@fastify/middie versions 9.3.1 and earlier do not register inherited middleware directly on child plugin engine instances. When a Fastify application registers authentication middleware in a parent scope and then registers child plugins with @fastify/middie, the child scope does not inherit the parent middleware. This allows unauthenticated requests to reach routes defined in child plugin scopes, bypassing authentication and authorization checks. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds.
Affected products
- fastify middie: before 9.3.2 — fixed in 9.3.2
How to fix
Upgrade to a fixed version: fastify middie 9.3.2. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/fastify/fastify-express/security/advisories/GHSA-hrwm-hgmj-7p9c
- https://github.com/fastify/middie/security/advisories/GHSA-72c6-fx6q-fr5w
Get alerted when CVE-2026-6270 or the next vulnerability affects your stack