What’s Vulnerable › Vulnerabilities

CVE-2026-6277: Incorrect Authorization in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 13.9 before 18.10.8, 18.11 before 18.11.5, and 19.0 before 19.0.2 that under certain conditions could have allowed an authenticated user with Security Manager-role permissions to manage project security configuration even when the relevant feature was in a disabled state, due to incorrect authorization enforcement.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.10.8, 18.11.5, 19.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-6277 or the next vulnerability affects your stack