What’s Vulnerable › Vulnerabilities
CVE-2026-6290: Velociraptor Query() Plugin Misapplies Permissions To Orgs
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-15 · updated 2026-10-26
- Weakness: CWE-863
Description
Velociraptor versions prior to 0.76.3 contain a vulnerability in the query() plugin which allows access to all orgs with the user's current ACL token. This allows an authenticated GUI user with access in one org, to use the query() plugin, in a notebook cell, to run VQL queries on other orgs which they may not have access to. The user's permissions in the other org are the same as the permissions they have in the org containing the notebook.
Affected products
- Rapid7 Velociraptor: before 0.76.3 — fixed in 0.76.3
How to fix
Upgrade to a fixed version: Rapid7 Velociraptor 0.76.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-6290 or the next vulnerability affects your stack