What’s Vulnerable › Vulnerabilities
CVE-2026-62946: ImageMagick: Integer Overflow in JNX decoder causes heap buffer over-write when processing extremly large files on 32-bit builds
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-30 · updated 2026-08-03
- Weakness: CWE-190
Description
ImageMagick is free and open-source software used for editing and manipulating digital images. In versions prior to both 6.9.13-52 and 7.1.2-27, processing an extremely large JNX file on 32-bit platforms can cause an integer overflow, leading to a heap buffer over-write. This issue has been fixed in versions 6.9.13-52 and 7.1.2-27.
Affected products
- ImageMagick: before 6.9.13-52; from 7.0.0-0 before 7.1.2-27 — fixed in 6.9.13-52, 7.1.2-27
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-52, 7.1.2-27. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-62946 or the next vulnerability affects your stack