What’s Vulnerable › Vulnerabilities
CVE-2026-62947: OpenWrt: ACL bypass and arbitrary root file read via cgi-io cgi-download
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-15 · updated 2026-07-21
- Weakness: CWE-22
Description
OpenWrt is a Linux operating system targeting embedded devices. Prior to 25.12.5, the cgi-download handler in cgi-io authorizes the requested path against the caller's ubus session file ACL before canonicalization, and rpcd session.c uses fnmatch() without FNM_PATHNAME, allowing traversal such as an allowed wildcard prefix followed by ../ to read root-readable files including /etc/shadow. This vulnerability is fixed in 25.12.5.
Affected products
- openwrt: before 25.12.5 — fixed in 25.12.5
How to fix
Upgrade to a fixed version: openwrt 25.12.5. Check the vendor advisory for mitigations.
References
- https://github.com/openwrt/cgi-io/commit/72990b7489872112df31c94032637c907760bae4
- https://github.com/openwrt/cgi-io/pull/4
- https://github.com/openwrt/openwrt/releases/tag/v25.12.5
- https://github.com/openwrt/openwrt/security/advisories/GHSA-jw5r-xhf5-2xcq
- https://github.com/openwrt/openwrt/security/advisories/GHSA-jw5r-xhf5-2xcq
Get alerted when CVE-2026-62947 or the next vulnerability affects your stack