What’s Vulnerable › Vulnerabilities
CVE-2026-62948: OpenWrt odhcpd/LuCI: unauthenticated DHCPv6 client can inject lease-file lines via FQDN hostname → stored XSS in the LuCI admin UI
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-15 · updated 2026-07-21
- Weakness: CWE-79
Description
OpenWrt is a Linux operating system targeting embedded devices. Prior to 25.12.5, odhcpd writes a DHCPv6 client FQDN option 39 hostname into /tmp/odhcpd.leases through src/statefiles.c statefiles_write_state6() and statefiles_write_state4() without escaping, allowing newline injection of forged lease lines that LuCI rpcd-mod-luci getDHCPLeases displays through htdocs/luci-static/resources/view/status/include/40_dhcp.js and htdocs/luci-static/resources/luci.js dom.append as live HTML in the Active DHCPv6 Leases admin page. This vulnerability is fixed in 25.12.5.
Affected products
- openwrt: before 25.12.5 — fixed in 25.12.5
How to fix
Upgrade to a fixed version: openwrt 25.12.5. Check the vendor advisory for mitigations.
References
- https://github.com/openwrt/luci/commit/55379d04fcc3c605003a5001d6135cf02ae6048a
- https://github.com/openwrt/odhcpd/commit/68f382690bfaec56d5b1f31c3c31c48bcb642e3a
- https://github.com/openwrt/odhcpd/pull/404
- https://github.com/openwrt/openwrt/releases/tag/v25.12.5
- https://github.com/openwrt/openwrt/security/advisories/GHSA-hhmc-92hw-535f
- https://github.com/openwrt/openwrt/security/advisories/GHSA-hhmc-92hw-535f
Get alerted when CVE-2026-62948 or the next vulnerability affects your stack