What’s Vulnerable › Vulnerabilities
CVE-2026-63030: WordPress Core Interpretation Conflict Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2026-07-21
- EPSS: 10.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-07-17 · updated 2026-10-08
- Weakness: CWE-436
Description
WordPress 6.9.x before 6.9.5 and 7.0.x before 7.0.2 is affected by a REST API batch endpoint route confusion issue which, combined with the author__not_in WP_Query SQL Injection (CVE-2026-60137), could allow an attacker to perform SQL Injection and achieve Remote Code Execution.
Affected products
- WordPress: from 6.9 before 6.9.5; from 7.0 before 7.0.2 — fixed in 6.9.5, 7.0.2
How to fix
Upgrade to a fixed version: WordPress 6.9.5, 7.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/WordPress/wordpress-develop/security/advisories/GHSA-ff9f-jf42-662q
- https://wordpress.org/news/2026/07/wordpress-7-0-2-release/
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-63030
Get alerted when CVE-2026-63030 or the next vulnerability affects your stack