What’s Vulnerable › Vulnerabilities
CVE-2026-63041: Apache APISIX: attach-consumer-label does not strip client-supplied consumer-label headers
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-26 · updated 2026-08-27
- Weakness: CWE-807
Description
Reliance on Untrusted Inputs in a Security Decision vulnerability in Apache APISIX. This vulnerability allows an attacker to escalate privilege or perform an authorization bypass by sending certain values that the attach-consumer-label plugin does not sanitise correctly. This issue affects Apache APISIX: from 3.11.0 through 3.17.0. Users are recommended to upgrade to version 3.18.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache APISIX: from 3.11.0 before 3.18.0 — fixed in 3.18.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache APISIX 3.18.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/yg9tgn699rz7kyglw82m1775do8frjr4
- http://www.openwall.com/lists/oss-security/2026/08/26/11
Get alerted when CVE-2026-63041 or the next vulnerability affects your stack