What’s Vulnerable › Vulnerabilities
CVE-2026-63045: Apache HTTP Server: mod_proxy_ftp PASV address handling
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-01 · updated 2026-10-05
- Weakness: CWE-284
Description
Improper validation of FTP PASV reply address in mod_proxy_ftp in Apache Software Foundation Apache HTTP Server through 2.4.68 on all platforms allows, in forward proxy configurations, an untrusted FTP server to cause the proxy to open a data connection to an arbitrary third-party host via a crafted PASV response. Users are recommended to upgrade to version 2.4.69, which fixes this issue.
Affected products
- Apache HTTP Server: from 2.4.0 before 2.4.69 — fixed in 2.4.69
How to fix
Upgrade to a fixed version: Apache HTTP Server 2.4.69. Check the vendor advisory for mitigations.
References
- https://httpd.apache.org/security/vulnerabilities_24.html
- http://www.openwall.com/lists/oss-security/2026/10/01/23
Get alerted when CVE-2026-63045 or the next vulnerability affects your stack