What’s Vulnerable › Vulnerabilities
CVE-2026-63102: rConfig Core < 8.2.8 Privilege Escalation via Users API role field
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-10-24
- Weakness: CWE-915
Description
rConfig Core before 8.2.8 contains a privilege escalation vulnerability that allows authenticated users to assign arbitrary roles to any account by submitting an unvalidated role field through the Users API during user creation or profile updates. Attackers can exploit the missing allowlist validation and absent admin-level authorization check in StoreUserRequest to mass-assign the Admin role directly to the User model, granting access to privileged features. rConfig Pro and Enterprise are not affected.
Affected products
- rconfig: before 8.2.8 — fixed in 8.2.8
How to fix
Upgrade to a fixed version: rconfig 8.2.8. Check the vendor advisory for mitigations.
References
- https://github.com/rconfig/rconfig/commit/84822f4051ed97d651b1b4d191c6da2aa8c3c037
- https://github.com/rconfig/rconfig/pull/325
- https://github.com/rconfig/rconfig/releases/tag/core-8.2.8
- https://www.vulncheck.com/advisories/rconfig-privilege-escalation-via-users-api-role-field
Get alerted when CVE-2026-63102 or the next vulnerability affects your stack