What’s Vulnerable › Vulnerabilities
CVE-2026-63140: Reachable Assertion in Elasticsearch Leading to Denial of Service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-21 · updated 2026-10-24
- Weakness: CWE-617
Description
Reachable Assertion (CWE-617) in Elasticsearch can lead to denial of service via Input Data Manipulation (CAPEC-153). A specially crafted search request containing a null value in a specific query clause causes an internal assertion to be raised during query parsing. Because Elasticsearch treats assertion failures as fatal errors, this terminates the affected node process. A low-privileged authenticated user with read access to at least one index can exploit this condition with a single request to cause a node to terminate, disrupting search availability. In a single-node deployment this fully stops Elasticsearch; in a multi-node cluster it reduces cluster capacity for each affected node.
Affected products
- Elasticsearch: from 8.0.0 before 8.19.19; from 9.0.0 before 9.3.8; from 9.4.0 before 9.4.4 — fixed in 8.19.19, 9.3.8, 9.4.4
How to fix
Upgrade to a fixed version: Elasticsearch 8.19.19, 9.3.8, 9.4.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-63140 or the next vulnerability affects your stack