What’s Vulnerable › Vulnerabilities
CVE-2026-63296: Project restriction bypass via instance migration config override
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-12 · updated 2026-10-24
- Weakness: CWE-863
Description
An authorization bypass vulnerability in LXD allows an authenticated attacker to bypass target project restrictions during instance migration. When migrating an instance to a target project, LXD accepts configuration overrides without validating the new configuration against the target project's enforced restrictions. An attacker can exploit this flaw to move instances with disallowed high-privilege configurations into restricted projects, bypassing security controls.
Affected products
- Canonical LXD: from 5.0.0 before 5.0.8; from 5.1 before 5.21.6; from 6.0 before 6.10 — fixed in 5.0.8, 5.21.6, 6.10
How to fix
Upgrade to a fixed version: Canonical LXD 5.0.8, 5.21.6, 6.10. Check the vendor advisory for mitigations.
References
- https://github.com/canonical/lxd/security/advisories/GHSA-gcr9-5q6r-w625
- https://github.com/canonical/lxd/security/advisories/GHSA-gcr9-5q6r-w625
Get alerted when CVE-2026-63296 or the next vulnerability affects your stack