What’s Vulnerable › Vulnerabilities
CVE-2026-63298: LXD arbitrary lxc.conf directive injection via NVIDIA instance configuration
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-12 · updated 2026-10-24
- Weakness: CWE-78
Description
An improper neutralization of special elements vulnerability in LXD's NVIDIA instance configuration handling allows an authenticated attacker to inject arbitrary configuration directives. By supplying newline characters within the 'nvidia.driver.capabilities' or 'nvidia.require.*' configuration values, an attacker can manipulate the generated lxc.conf file. This flaw enables the attacker to execute arbitrary code on the host system with the privileges of the LXD daemon.
Affected products
- Canonical LXD: from 4.0.0 before 4.0.12; from 5.0.0 before 5.0.8; from 5.1 before 5.21.6; from 6.0 through 6.9 — fixed in 4.0.12, 5.0.8, 5.21.6
How to fix
Upgrade to a fixed version: Canonical LXD 4.0.12, 5.0.8, 5.21.6. Check the vendor advisory for mitigations.
References
- https://github.com/canonical/lxd/security/advisories/GHSA-vfh7-q59q-54v2
- https://github.com/canonical/lxd/security/advisories/GHSA-vfh7-q59q-54v2
Get alerted when CVE-2026-63298 or the next vulnerability affects your stack