What’s Vulnerable › Vulnerabilities
CVE-2026-6335: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-14 · updated 2026-06-17
- Weakness: CWE-79
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.11 before 18.11.3 that under certain conditions could have allowed an authenticated user to execute arbitrary code in another user's browser session due to improper sanitization.
Affected products
- GitLab: from 18.11.0 before 18.11.3 — fixed in 18.11.3
How to fix
Upgrade to a fixed version: GitLab 18.11.3. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2026/05/13/patch-release-gitlab-18-11-3-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/596760
- https://hackerone.com/reports/3673647
Get alerted when CVE-2026-6335 or the next vulnerability affects your stack