What’s Vulnerable › Vulnerabilities

CVE-2026-6346: Sensitive credentials exposed in plaintext in Mattermost support packets

Description

Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to sanitize sensitive configuration fields before including them in support packet generation, which allows a Mattermost System Admin or any party with access to a support packet to obtain sensitive credentials in plaintext via downloading a support packet from the System Console.. Mattermost Advisory ID: MMSA-2026-00607

Affected products

How to fix

Upgrade to a fixed version: Mattermost 10.11.14, 11.4.4, 11.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-6346 or the next vulnerability affects your stack