What’s Vulnerable › Vulnerabilities
CVE-2026-63626: Mongoose: ppp_handle_ipv6cp() uses attacker-controlled length without bounds check — OOB read and heap overflow (PPP/PPPoE, MG_ENABLE_IPV6)
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-16
- Weakness: CWE-122
Description
Mongoose is an embedded web server and network library. Prior to 7.23, ppp_handle_ipv6cp() in src/l2_ppp.c trusts the 16-bit IPv6CP len field without checking it against the received payload size. On a PPP or PPPoE link using MG_ENABLE_TCPIP and MG_ENABLE_IPV6, an unauthenticated adjacent peer can complete the required LCP exchange and send a short Configure-Request with an oversized length, causing ppp_tx_frame() to read beyond recv_queue.buf and write beyond tx.buf. The same length misuse can also expose adjacent heap bytes in a reply or hang the event loop through find_opt(). This issue is fixed in version 7.23.
Affected products
- Cesanta Mongoose: before 7.23
References
- https://github.com/cesanta/mongoose/commit/751f14742dea934bec08a507ab1fecc3673d4903
- https://github.com/cesanta/mongoose/releases/tag/7.23
- https://github.com/cesanta/mongoose/security/advisories/GHSA-pc66-j6r6-49x9
Get alerted when CVE-2026-63626 or the next vulnerability affects your stack