What’s Vulnerable › Vulnerabilities
CVE-2026-63638: OpenImageIO: Cineon invalid bit depth heap out-of-bounds write
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-18 · updated 2026-09-29
- Weakness: CWE-787
Description
OpenImageIO is a toolset for reading, writing, and manipulating image files of any image file format relevant to VFX / animation. Prior to 3.0.21.0, 3.1.16.0, and 3.2.0.3-beta1, A crafted cineon image can declare unsupported component bit depth 26. cineoninput::open() maps it to a 32-bit imagespec, but libcineon maps the unsupported depth to an 8-byte value, so cineoninput::read_native_scanline() causes attacker-controlled data to be written beyond the 4-byte-per-pixel caller buffer, resulting in a heap out-of-bounds write and memory corruption. The affected implementation is identified by src/cineon.imageio/cineoninput.cpp, CineonInput::open(), CineonInput::read_native_scanline(), ComponentDataSize(), bit depth 26, and ImageSpec, which define the relevant source path, functions, state, and trigger. This issue is fixed in versions 3.0.21.0, 3.1.16.0, and 3.2.0.3-beta1.
Affected products
- OpenImageIO Project OpenImageIO: before 3.0.21.0; from 3.1.0.0 through 3.1.16.0; 3.2.0.0-dev, 3.2.0.2-dev — fixed in 3.0.21.0
How to fix
Upgrade to a fixed version: OpenImageIO Project OpenImageIO 3.0.21.0. Check the vendor advisory for mitigations.
References
- https://github.com/AcademySoftwareFoundation/OpenImageIO/commit/6f2b2e85b3b3933ccc5a46303d5535f99bfa39fb
- https://github.com/AcademySoftwareFoundation/OpenImageIO/pull/5283
- https://github.com/AcademySoftwareFoundation/OpenImageIO/releases/tag/v3.0.21.0
- https://github.com/AcademySoftwareFoundation/OpenImageIO/releases/tag/v3.1.16.0
- https://github.com/AcademySoftwareFoundation/OpenImageIO/security/advisories/GHSA-9hxv-jvgr-3x8g
- https://github.com/AcademySoftwareFoundation/OpenImageIO/security/advisories/GHSA-9hxv-jvgr-3x8g
Get alerted when CVE-2026-63638 or the next vulnerability affects your stack