What’s Vulnerable › Vulnerabilities
CVE-2026-6365: Drupal core - Critical - Cross-site scripting - SA-CORE-2026-001
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-19 · updated 2026-07-24
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal Drupal core allows Cross-Site Scripting (XSS). This issue affects Drupal core: from 8.0.0 before 10.5.9, from 10.6.0 before 10.6.7, from 11.0.0 before 11.2.11, from 11.3.0 before 11.3.7.
Affected products
- Drupal: from 8.0.0 before 10.5.9; from 10.6.0 before 10.6.7; from 11.0.0 before 11.2.11; from 11.3.0 before 11.3.7 — fixed in 10.5.9, 10.6.7, 11.2.11, 11.3.7
How to fix
Upgrade to a fixed version: Drupal 10.5.9, 10.6.7, 11.2.11, 11.3.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-6365 or the next vulnerability affects your stack