What’s Vulnerable › Vulnerabilities
CVE-2026-63730: HyperDX < 2.31.0 SSRF via Webhook Test Endpoint
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-10-24
- Weakness: CWE-918
Description
HyperDX before 2.31.0 contains a server-side request forgery vulnerability that allows authenticated team members to direct the server to make requests to arbitrary internal network destinations by supplying a caller-controlled URL to the webhook test endpoint. Attackers can bypass the insufficient hostname blacklist validation in the webhook handler to enumerate internal services, interact with internal containers, or access cloud instance metadata services including provider metadata endpoints.
Affected products
- hyperdxio hyperdx: from 2.0.0 before 2.31.0 — fixed in 2.31.0
How to fix
Upgrade to a fixed version: hyperdxio hyperdx 2.31.0. Check the vendor advisory for mitigations.
References
- https://github.com/hyperdxio/hyperdx/commit/1705b37ac68acc222cd038327ed79e167e256a1b
- https://github.com/hyperdxio/hyperdx/issues/2588
- https://github.com/hyperdxio/hyperdx/pull/2593
- https://github.com/hyperdxio/hyperdx/releases/tag/%40hyperdx%2Fapp%402.31.0
- https://www.vulncheck.com/advisories/hyperdx-ssrf-via-webhook-test-endpoint
Get alerted when CVE-2026-63730 or the next vulnerability affects your stack