What’s Vulnerable › Vulnerabilities
CVE-2026-63732: 9router before 0.4.60 Remote Code Execution via default password
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-23 · updated 2026-10-24
- Weakness: CWE-78
Description
9router 0.4.59 (fixed in 0.4.60) contains a chain of vulnerabilities: a hardcoded default password (123456) that authenticates any fresh installation, a bypass of the LOCAL_ONLY network gate via a spoofed Host header, and unvalidated arguments passed to child_process.spawn() when registering MCP plugins. A remote, unauthenticated attacker can log in with the default credential, spoof the Host header to reach local-only routes, and register a malicious MCP plugin (e.g. node -e <payload>) to achieve arbitrary code execution on the host operating system when the plugin's SSE endpoint is triggered.
Affected products
- decolua 9router: before 0.4.60 — fixed in 0.4.60
How to fix
Upgrade to a fixed version: decolua 9router 0.4.60. Check the vendor advisory for mitigations.
References
- https://github.com/decolua/9router/security/advisories/GHSA-4922-8r65-fq26
- https://www.vulncheck.com/advisories/9router-before-remote-code-execution-via-default-password
Get alerted when CVE-2026-63732 or the next vulnerability affects your stack