What’s Vulnerable › Vulnerabilities
CVE-2026-63733: SurrealDB before 3.2.0 Permissions Bypass via PERMISSIONS Clause
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-07-22
- Weakness: CWE-863
Description
SurrealDB versions before 3.2.0 contain a permissions bypass vulnerability where data-modifying statements within PERMISSIONS clauses execute with enforcement disabled. Attackers with permission to perform a guarded operation can write to tables they lack permission for by embedding CREATE, UPDATE, DELETE, or UPSERT statements in the PERMISSIONS clause, causing unintended writes and data corruption.
Affected products
- surrealdb: before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: surrealdb 3.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-66r2-5gwj-gxm2
- https://www.vulncheck.com/advisories/surrealdb-before-permissions-bypass-via-permissions-clause
Get alerted when CVE-2026-63733 or the next vulnerability affects your stack