What’s Vulnerable › Vulnerabilities
CVE-2026-63734: SurrealDB before 3.2.0 Denial of Service via malformed SurrealML import
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-10-24
- Weakness: CWE-20
Description
SurrealDB versions before 3.2.0 contain a denial of service vulnerability in the SurrealML header parser that allows authenticated Owner-role users to crash the server by uploading a malformed .surml file to the /ml/import endpoint. Attackers can supply non-numeric input-dimensions or other malformed header fields that trigger unchecked unwrap calls, causing a panic that aborts the entire server process and denies service to all databases.
Affected products
- surrealdb: before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: surrealdb 3.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-jwr6-6444-28xv
- https://www.vulncheck.com/advisories/surrealdb-before-denial-of-service-via-malformed-surrealml-import
Get alerted when CVE-2026-63734 or the next vulnerability affects your stack