What’s Vulnerable › Vulnerabilities
CVE-2026-63735: SurrealDB before 3.2.0 Authentication Bypass via Custom API
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-07-23
- Weakness: CWE-639
Description
SurrealDB versions before 3.2.0 fail to validate namespace and database scope in custom API routes, allowing authenticated users to invoke endpoints in different namespaces/databases. Attackers with valid credentials for any namespace/database can access custom API endpoints in other tenants by specifying the target scope in the URL path, reading sensitive data or triggering unintended operations.
Affected products
- surrealdb: before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: surrealdb 3.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-848m-r628-vrxw
- https://www.vulncheck.com/advisories/surrealdb-before-authentication-bypass-via-custom-api
Get alerted when CVE-2026-63735 or the next vulnerability affects your stack