What’s Vulnerable › Vulnerabilities
CVE-2026-63737: SurrealDB before 3.1.5 Denial of Service via deep operator chains
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-07-22
- Weakness: CWE-674
Description
SurrealDB versions before 3.1.5 contain a denial of service vulnerability where authenticated users can crash the server with queries containing long chains of operators. Attackers can submit queries with tens of thousands of chained operators that create unbounded expression trees, causing stack overflow during query processing and aborting the entire process.
Affected products
- surrealdb: from 3.0.0 before 3.1.5 — fixed in 3.1.5
How to fix
Upgrade to a fixed version: surrealdb 3.1.5. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-jv2j-mqmw-xvv5
- https://www.vulncheck.com/advisories/surrealdb-before-denial-of-service-via-deep-operator-chains
Get alerted when CVE-2026-63737 or the next vulnerability affects your stack