What’s Vulnerable › Vulnerabilities
CVE-2026-63738: SurrealDB 3.1.0 before 3.1.5 Field Permission Bypass via Traversal
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-07-22
- Weakness: CWE-863
Description
SurrealDB versions 3.1.0 before 3.1.5 fail to enforce field-level SELECT permissions when records are accessed through graph-edge or back-reference traversals. Attackers with table-level SELECT access can read field values hidden by field-level permissions by materializing records through graph traversals instead of direct table scans.
Affected products
- surrealdb: from 3.1.0 before 3.1.5 — fixed in 3.1.5
How to fix
Upgrade to a fixed version: surrealdb 3.1.5. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-hv6h-hc26-q48p
- https://www.vulncheck.com/advisories/surrealdb-before-field-permission-bypass-via-traversal
Get alerted when CVE-2026-63738 or the next vulnerability affects your stack