What’s Vulnerable › Vulnerabilities
CVE-2026-63741: SurrealDB before 3.1.0 Authentication Bypass via USE statement
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-07-23
- Weakness: CWE-862
Description
SurrealDB versions before 3.1.0 fail to validate DEFINE NAMESPACE or DEFINE DATABASE permissions when processing USE NS and USE DB statements. Unauthenticated attackers can create arbitrary namespaces and databases by issuing USE commands, bypassing authorization checks in the RPC use method and SurrealQL executor.
Affected products
- surrealdb: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: surrealdb 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-wp87-mgvq-5j93
- https://www.vulncheck.com/advisories/surrealdb-before-authentication-bypass-via-use-statement
Get alerted when CVE-2026-63741 or the next vulnerability affects your stack