What’s Vulnerable › Vulnerabilities
CVE-2026-63747: SurrealDB before 3.1.0 Denial of Service via malformed RPC use
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-07-23
- Weakness: CWE-248
Description
SurrealDB versions before 3.1.0 contain a denial of service vulnerability in the RPC use handler that panics when db is set without a namespace. Unauthenticated attackers can send a malformed WebSocket message to the /rpc endpoint to crash the server process.
Affected products
- surrealdb: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: surrealdb 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-wjjj-24cx-f28g
- https://www.vulncheck.com/advisories/surrealdb-before-denial-of-service-via-malformed-rpc-use
Get alerted when CVE-2026-63747 or the next vulnerability affects your stack