What’s Vulnerable › Vulnerabilities
CVE-2026-63752: SurrealDB before 3.1.0 RELATE Statement Record Overwrite
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-07-22
- Weakness: CWE-285
Description
SurrealDB before 3.1.0 contains an authorization bypass vulnerability in the RELATE statement that allows authenticated users with CREATE permission to overwrite existing edge records without UPDATE permission. Attackers can issue a RELATE statement with a SET id clause pointing to an existing edge id, causing the storage layer to silently overwrite the target record instead of rejecting the operation.
Affected products
- surrealdb: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: surrealdb 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-f82j-v89j-mf86
- https://www.vulncheck.com/advisories/surrealdb-before-relate-statement-record-overwrite
Get alerted when CVE-2026-63752 or the next vulnerability affects your stack