What’s Vulnerable › Vulnerabilities
CVE-2026-63755: SurrealDB before 3.1.0 Permission Bypass via WHERE Clause
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-07-22
- Weakness: CWE-863
Description
SurrealDB before 3.1.0 evaluates user-supplied WHERE clauses in SELECT statements (and SET/MERGE/CONTENT/PATCH clauses in UPDATE, UPSERT, INSERT ON DUPLICATE KEY UPDATE, and RELATE update-variant statements) against full record data before enforcing PERMISSIONS FOR SELECT WHERE restrictions. An authenticated user — including Record and Scope users — can exploit this ordering flaw to read the full contents of any table in the database they are authenticated against, bypassing table-level permission checks. Exfiltration is most direct when scripting functions are enabled (--allow-scripting), but is also possible via SurrealQL's THROW statement and timing-based side channels without scripting. The vulnerability is confined to the attacker's current database and does not cross namespace or database isolation boundaries.
Affected products
- surrealdb: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: surrealdb 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-98fx-66cf-fc7c
- https://www.vulncheck.com/advisories/surrealdb-before-permission-bypass-via-where-clause
Get alerted when CVE-2026-63755 or the next vulnerability affects your stack