What’s Vulnerable › Vulnerabilities
CVE-2026-63759: SurrealDB before 3.1.0 Denial of Service nested type annotations
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-07-23
- Weakness: CWE-674
Description
SurrealDB before 3.1.0 fails to enforce recursion depth limits in the type/kind parser when processing nested type annotations. Authenticated attackers can send queries with deeply nested type annotations to exhaust server memory and crash the process.
Affected products
- surrealdb: before 3.1.0 — fixed in 3.1.0
How to fix
Upgrade to a fixed version: surrealdb 3.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-q8qp-67f9-wr3f
- https://www.vulncheck.com/advisories/surrealdb-before-denial-of-service-nested-type-annotations
Get alerted when CVE-2026-63759 or the next vulnerability affects your stack