What’s Vulnerable › Vulnerabilities
CVE-2026-63762: SurrealDB before v2.6.1 Denial of Service via scripting
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-07-22
- Weakness: CWE-476
Description
SurrealDB before v2.6.1 (and before v3.0.0-beta.3) contains a denial of service vulnerability in its embedded JavaScript scripting engine, which is enabled via the --allow-scripting capability (disabled by default). Any user able to execute arbitrary queries — including unauthenticated guests when --allow-guests is enabled — can use built-in string functions to construct a large string and pass it to the JavaScript runtime for compilation, triggering a null pointer dereference in the underlying QuickJS-NG engine. This causes the server process to terminate immediately without graceful shutdown, requiring a manual restart. The issue was fixed by updating the rquickjs dependency from v0.9.0 to v0.11.0.
Affected products
- surrealdb: before 2.6.1; 3.0.0-alpha1, 3.0.0-alpha10, 3.0.0-alpha11, 3.0.0-alpha12, 3.0.0-alpha13, 3.0.0-alpha14 (+13) — fixed in 2.6.1
How to fix
Upgrade to a fixed version: surrealdb 2.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-xx7m-69ff-9crp
- https://www.vulncheck.com/advisories/surrealdb-before-denial-of-service-via-scripting
Get alerted when CVE-2026-63762 or the next vulnerability affects your stack