What’s Vulnerable › Vulnerabilities
CVE-2026-63763: SurrealDB before 2.5.0 Privilege Escalation via Future Fields
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-20 · updated 2026-07-22
- Weakness: CWE-639
Description
SurrealDB before 2.5.0 and before 3.0.0-beta.3 contains a confused deputy privilege escalation vulnerability. Unprivileged users (e.g., those with the database editor role) can create or modify fields containing futures, functions, or closures. Because these are executed in the context of the invoking/querying user rather than their creator, an attacker can plant malicious logic that executes with a higher-privileged user's permissions when that user reads or writes the affected record. This can lead to full privilege escalation, including creation of a root owner and server takeover.
Affected products
- surrealdb: before 2.5.0; 3.0.0-alpha1, 3.0.0-alpha10, 3.0.0-alpha11, 3.0.0-alpha12, 3.0.0-alpha13, 3.0.0-alpha14 (+13) — fixed in 2.5.0
How to fix
Upgrade to a fixed version: surrealdb 2.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-3v2x-9xcv-2v2v
- https://www.vulncheck.com/advisories/surrealdb-before-privilege-escalation-via-future-fields
Get alerted when CVE-2026-63763 or the next vulnerability affects your stack