What’s Vulnerable › Vulnerabilities
CVE-2026-6382: Multiple elFinder Plugins - Authenticated OS Command Injection
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-06 · updated 2026-07-06
Description
The FileOrganizer WordPress plugin before 1.1.9, Advanced File Manager WordPress plugin before 5.4.12, File Manager Pro WordPress plugin before 2.1.1, File Manager WordPress plugin before 8.0.4 do not properly escape a parameter before passing it to a shell command when processing image operations, allowing authenticated users to perform OS Command Injection. This requires the server to have the ImageMagick convert CLI available without either the PHP imagick or GD extensions.
Affected products
- saadiqbal Advanced File Manager – Ultimate File Manager for WordPress And Document Library Solution: before 5.4.12 — fixed in 5.4.12
- FileOrganizer: before 1.1.9 — fixed in 1.1.9
- File Manager: before 8.0.4 — fixed in 8.0.4
- File Manager Pro: before 2.1.1 — fixed in 2.1.1
How to fix
Upgrade to a fixed version: saadiqbal Advanced File Manager – Ultimate File Manager for WordPress And Document Library Solution 5.4.12; FileOrganizer 1.1.9; File Manager 8.0.4; File Manager Pro 2.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-6382 or the next vulnerability affects your stack