What’s Vulnerable › Vulnerabilities
CVE-2026-63824: KEYS: fix overflow in keyctl_pkey_params_get_2()
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-10-22
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: KEYS: fix overflow in keyctl_pkey_params_get_2() The length for the internal output buffer is calculated incorrectly, which can result overflow when a too small buffer is provided. Fix the bug by allocating internal output with the size of the maximum length of the cryptographic primitive instead of caller provided size.
Affected products
- Linux kernel: from 4.20 before 5.10.260; from 5.11 before 5.15.211; from 5.16 before 6.1.177; from 6.2 before 6.6.144; from 6.7 before 6.12.95; from 6.13 before 6.18.38 — fixed in 5.10.260, 5.15.211, 6.1.177, 6.12.95, 6.18.38, 6.6.144
How to fix
Upgrade to a fixed version: Linux kernel 5.10.260, 5.15.211, 6.1.177, 6.12.95. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0f3058d7d26f81df9b68a18ddbe164bdc3c5eff3
- https://git.kernel.org/stable/c/5165f1cc727f1322456735df212d8e26ec237a8d
- https://git.kernel.org/stable/c/5966e4e2ba213ab7ad559166152eb4f1f170dd2c
- https://git.kernel.org/stable/c/622ec2dcd59f21623f2a7ab773c80ceb7d555e3a
- https://git.kernel.org/stable/c/670fc6a311ed321522b7fff92cf0fc376b4f6e78
- https://git.kernel.org/stable/c/b11c1fa32667692a2c0566e10163758e786e430c
- https://git.kernel.org/stable/c/b1e247338bc71826a2d2def3e0874c34749df69a
- https://git.kernel.org/stable/c/cb481e59ea6cae3b7796ac1d7a22b6b24c3f3c0b
Get alerted when CVE-2026-63824 or the next vulnerability affects your stack