What’s Vulnerable › Vulnerabilities
CVE-2026-63855: drm/amdgpu/vcn: set no_user_fence for VCN v2.5 enc/dec rings
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-10-30
- Weakness: CWE-20
Description
In the Linux kernel, the following vulnerability has been resolved: drm/amdgpu/vcn: set no_user_fence for VCN v2.5 enc/dec rings VCN encoder and decoder rings do not support 64-bit user fence writes, reject CS submissions with user fences. (cherry picked from commit efc9dd5590894109bce9a0bfe1fa5592dd6b20b1)
Affected products
- Linux kernel: from 5.4 before 6.6.141; from 6.7 before 6.12.91; from 6.13 before 6.18.33; from 6.19 before 7.0.10; 7.1-rc1 — fixed in 6.6.141, 6.12.91, 6.18.33, 7.0.10
- Linux: 5.4 — fixed in 7.1
How to fix
Upgrade to a fixed version: Linux kernel 6.6.141, 6.12.91, 6.18.33, 7.0.10; Linux 7.1. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2c6fb056567efb49f8674108b86088a1cfaa86d0
- https://git.kernel.org/stable/c/4f317863a3ab212a027d8c8c3cc3af4e3fb95704
- https://git.kernel.org/stable/c/5a3c6f76cab164a5d803084908d7050f649ab7f9
- https://git.kernel.org/stable/c/602d4c5872b25ddd4d82fb2025efb9a05b187bb3
- https://git.kernel.org/stable/c/8156e258025f2a22fcf7486c96848ac3cd3541dd
- https://git.kernel.org/stable/c/8f0ea4524dc71c6c9ec97f2711f46e12f624140f
Get alerted when CVE-2026-63855 or the next vulnerability affects your stack