What’s Vulnerable › Vulnerabilities
CVE-2026-63902: USB: serial: cypress_m8: validate interrupt packet headers
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-10-30
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: USB: serial: cypress_m8: validate interrupt packet headers cypress_read_int_callback() parses the interrupt-in buffer according to the selected Cypress packet format. Format 1 has a two-byte status/count header and format 2 has a one-byte combined status/count header. The usb-serial core sizes the interrupt-in buffer from the endpoint descriptor's wMaxPacketSize, and successful interrupt transfers can complete short when URB_SHORT_NOT_OK is not set. Check that the completed packet contains the selected header before reading it. Malformed short reports are ignored and the interrupt URB is resubmitted through the existing retry path, preventing out-of-bounds header-byte reads. KASAN report as below: KASAN slab-out-of-bounds in cypress_read_int_callback+0x240/0x7f0 Read of size 1 Call trace: cypress_read_int_callback() (drivers/usb/serial/cypress_m8.c:1009) __usb_hcd_giveback_urb() dummy_timer() [ johan: use constants in header length sanity checks ]
Affected products
- Linux kernel: from 2.6.26 before 5.10.259; from 5.11 before 5.15.210; from 5.16 before 6.1.176; from 6.2 before 6.6.143; from 6.7 before 6.12.93; from 6.13 before 6.18.35 — fixed in 5.10.259, 5.15.210, 6.1.176, 6.6.143, 6.12.93, 6.18.35
- Linux kernel: 2.6.26 — fixed in 7.1
How to fix
Upgrade to a fixed version: Linux kernel 5.10.259, 5.15.210, 6.1.176, 6.6.143; Linux kernel 7.1. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/44f9bab8df7750a1e2a4d6cc22d7c9c2dc096aed
- https://git.kernel.org/stable/c/4a4cb0021ebe1fcadb52e04d19ed8d71470a530b
- https://git.kernel.org/stable/c/90664556916de22467097d4c8ceb716d597a5c32
- https://git.kernel.org/stable/c/9f9bfc80c67f35a275820da7e83a35dface08281
- https://git.kernel.org/stable/c/aaa66708bfb1dca2acd219d1c1582f9f6d5492cb
- https://git.kernel.org/stable/c/ae03453f2c809ca3cf73753269fa6184dea7160f
- https://git.kernel.org/stable/c/be50533fe7068e86eb7adb81988e6d6a3f6dfe53
- https://git.kernel.org/stable/c/fcef31a5a85ccf3c313449a866ec6ed7e4132425
Get alerted when CVE-2026-63902 or the next vulnerability affects your stack