What’s Vulnerable › Vulnerabilities
CVE-2026-63937: KVM: SEV: Use READ_ONCE() when reading entries/indices from PSC buffer
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-10-27
- Weakness: CWE-367
Description
In the Linux kernel, the following vulnerability has been resolved: KVM: SEV: Use READ_ONCE() when reading entries/indices from PSC buffer Use READ_ONCE() when reading entries/indices from the guest-accessible Page State Change buffer to defend against TOCTOU bugs. Don't bother with READ_ONCE()/WRITE_ONCE() for cases where KVM is writing (and not consuming the result!), as the guest isn't supposed to touch the buffer while it's being processed. I.e. using READ_ONCE() is all about protecting against misbehaving guests.
Affected products
- Linux kernel: from 6.11 before 6.12.93; from 6.13 before 6.18.35; from 6.19 before 7.0.12; 7.1-rc1, 7.1-rc2, 7.1-rc3, 7.1-rc4, 7.1-rc5 — fixed in 6.12.93, 6.18.35, 7.0.12
- Linux kernel: 6.11 — fixed in 7.1
How to fix
Upgrade to a fixed version: Linux kernel 6.12.93, 6.18.35, 7.0.12; Linux kernel 7.1. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/b1dfaa6f7a957726a6800135be3659fbe4bbf2a4
- https://git.kernel.org/stable/c/bd232801ef1d1fd985d2d4ca3cd1d888303ca86f
- https://git.kernel.org/stable/c/c8cc238093ca6c99267032f6cfe78f59389f3157
- https://git.kernel.org/stable/c/edbbe88f83b524434974e84808d3093199d67c24
Get alerted when CVE-2026-63937 or the next vulnerability affects your stack