What’s Vulnerable › Vulnerabilities
CVE-2026-63938: KVM: SEV: Check PSC request indices against the actual size of the buffer
- Severity: critical (CVSS 9.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-10-27
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: KVM: SEV: Check PSC request indices against the actual size of the buffer When processing Page State Change (PSC) requests, validate the PSC buffer against the effective size of the scratch area, which could be less than the maximum size if the guest provided a pointer that isn't exactly at the start of the GHCB shared buffer.
Affected products
- Linux kernel: from 6.11 before 6.12.93; from 6.13 before 6.18.35; from 6.19 before 7.0.12; 7.1-rc1, 7.1-rc2, 7.1-rc3, 7.1-rc4, 7.1-rc5 — fixed in 6.12.93, 6.18.35, 7.0.12
- Linux kernel: 6.11 — fixed in 7.1
How to fix
Upgrade to a fixed version: Linux kernel 6.12.93, 6.18.35, 7.0.12; Linux kernel 7.1. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/121d88de56bc5c0ba0ce2f6381af67f948a7e7c1
- https://git.kernel.org/stable/c/505a3b94535583e4265360e2621734e355ef263d
- https://git.kernel.org/stable/c/5198f70c09a5f6e9e5f5a0a2c6b388f24294b176
- https://git.kernel.org/stable/c/75c8d1d7291268b479794fba5808971dc2f5eaf3
Get alerted when CVE-2026-63938 or the next vulnerability affects your stack