What’s Vulnerable › Vulnerabilities
CVE-2026-63958: usb: typec: ucsi: validate connector number in ucsi_connector_change()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-10-30
Description
In the Linux kernel, the following vulnerability has been resolved: usb: typec: ucsi: validate connector number in ucsi_connector_change() The connector number in a UCSI CCI notification is a 7-bit field supplied by the PPM. ucsi_connector_change() uses it to index the ucsi->connector[] array without checking it against the number of connectors the PPM reported at init time, so a buggy or malicious PPM (EC firmware, or an I2C-attached UCSI controller on the ccg / stm32g0 / glink transports) can drive schedule_work() on memory past the end of the array. Reject connector numbers that are zero or exceed cap.num_connectors before dereferencing the array.
Affected products
- Linux kernel: from 4.13 before 6.1.176; from 6.2 before 6.6.143; from 6.7 before 6.12.93; from 6.13 before 6.18.35; from 6.19 before 7.0.12; 7.1-rc1, 7.1-rc2, 7.1-rc3, 7.1-rc4, 7.1-rc5 — fixed in 6.1.176, 6.6.143, 6.12.93, 6.18.35, 7.0.12
- Linux kernel: 4.13 — fixed in 7.1
How to fix
Upgrade to a fixed version: Linux kernel 6.1.176, 6.6.143, 6.12.93, 6.18.35; Linux kernel 7.1. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0edd1e21587b0483c7ceb993b9fb9668bbef7433
- https://git.kernel.org/stable/c/156b6f0aec6108909b0c4aedc78865b12766b347
- https://git.kernel.org/stable/c/288a81a8507052bcfbf884d39a463c44c42c5fd9
- https://git.kernel.org/stable/c/5af2719b460ab904c504fc069d1dd2a3aa2b22b0
- https://git.kernel.org/stable/c/bd24d92af4ae021b6209f28e9a57e1bf2260d4fd
- https://git.kernel.org/stable/c/cea949203faef9cb783adc7b978cce056271e057
Get alerted when CVE-2026-63958 or the next vulnerability affects your stack