What’s Vulnerable › Vulnerabilities
CVE-2026-63960: usb: typec: wcove: don't write past struct pd_message in wcove_read_rx_buffer()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-10-30
Description
In the Linux kernel, the following vulnerability has been resolved: usb: typec: wcove: don't write past struct pd_message in wcove_read_rx_buffer() wcove_read_rx_buffer() copies the PD RX FIFO into the caller's struct pd_message with for (i = 0; i < USBC_RXINFO_RXBYTES(info); i++) regmap_read(wcove->regmap, USBC_RX_DATA + i, msg + i); which has two problems: USBC_RXINFO_RXBYTES() is a 5-bit field (max 31) while struct pd_message is 30 bytes (__le16 header + __le32 payload[PD_MAX_PAYLOAD], packed). The byte count latched in RXINFO is the number of bytes the port partner put on the wire, so a malicious partner that transmits a 31-byte frame can drive the loop one byte past the destination if the WCOVE BMC receiver does not enforce the PD object-count limit in hardware. The existing FIXME flagged this as unverified. Independently, regmap_read() takes an unsigned int * and stores a full unsigned int at the destination. Passing the byte pointer msg + i means each iteration writes four bytes; the high three are zero (val_bits is 8) and are normally overwritten by the next iteration, but the final iteration's high bytes are not. With RXBYTES == 30 the i == 29 iteration already writes three zero bytes past msg, which sits on the IRQ thread's stack in wcove_typec_irq(). Clamp the loop to sizeof(struct pd_message) and read each register into a local before storing only its low byte, so the copy can never exceed the destination regardless of what RXINFO reports.
Affected products
- Linux kernel: from 4.15 before 5.10.259; from 5.11 before 5.15.210; from 5.16 before 6.1.176; from 6.2 before 6.6.143; from 6.7 before 6.12.93; from 6.13 before 6.18.35 — fixed in 5.10.259, 5.15.210, 6.1.176, 6.6.143, 6.12.93, 6.18.35
- Linux kernel: 4.15 — fixed in 7.1
How to fix
Upgrade to a fixed version: Linux kernel 5.10.259, 5.15.210, 6.1.176, 6.6.143; Linux kernel 7.1. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3e632098d0521257ea965bbd6fde807d9bee5c8a
- https://git.kernel.org/stable/c/3f9d50c8b02b4af0646aa892465080f9061fc89c
- https://git.kernel.org/stable/c/4af7ad0e6d7aa4403dbb1dac7b9659b0421efcaa
- https://git.kernel.org/stable/c/5cd0e7ac4eefbdb330f8c72694fe74e63df65552
- https://git.kernel.org/stable/c/6899f5b6d7b83ce79a3d331dc61dd31bf73f9c22
- https://git.kernel.org/stable/c/d0e4b8b3c6b7607a16932556eaaca5d5cf69f192
- https://git.kernel.org/stable/c/e94933dc41b87503bf585c8c6d53d740620eceb9
- https://git.kernel.org/stable/c/f2a1edc0bd142edabc6c85d88713f2bc178dd317
Get alerted when CVE-2026-63960 or the next vulnerability affects your stack