What’s Vulnerable › Vulnerabilities
CVE-2026-63962: usb: typec: tcpm: bound altmode_desc[] per iteration in svdm_consume_modes()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-10-30
Description
In the Linux kernel, the following vulnerability has been resolved: usb: typec: tcpm: bound altmode_desc[] per iteration in svdm_consume_modes() svdm_consume_modes() checks pmdata->altmodes against the array size once before the loop over the count, but forgot to check the bound at every point in the loop. In the well-behaved SVDM discovery flow this is harmless because each of at most SVID_DISCOVERY_MAX SVIDs contributes at most MODE_DISCOVERY_MAX modes, exactly filling altmode_desc[ALTMODE_DISCOVERY_MAX]. But the CMDT_RSP_ACK handler in tcpm_pd_svdm() does not correlate an incoming ACK with any request the port actually sent. Once port->partner is set, an unsolicited Discover Modes ACK is consumed unconditionally. A broken or malicious port partner can therefore drive altmodes to ALTMODE_DISCOVERY_MAX - 1 via the normal flow, and then send one extra Discover Modes ACK with seven VDOs. Because the pre-loop check passes, the loop could then writes up to five entries past altmode_desc[]. For mode_data_prime the next field in struct tcpm_port is the partner_altmode[] pointer array, which then receives partner-chosen SVID/VDO bytes. Move the bound check inside the loop so the array can never be indexed past ALTMODE_DISCOVERY_MAX regardless of how many VDOs the partner supplies or how the function was reached.
Affected products
- Linux kernel: from 4.19 before 6.1.191; from 6.2 before 6.6.160; from 6.7 before 6.12.93; from 6.13 before 6.18.35; from 6.19 before 7.0.12; 7.1-rc1, 7.1-rc2, 7.1-rc3, 7.1-rc4, 7.1-rc5 — fixed in 6.1.191, 6.6.160, 6.12.93, 6.18.35, 7.0.12
- Linux: 4.19 — fixed in 7.1
How to fix
Upgrade to a fixed version: Linux kernel 6.1.191, 6.6.160, 6.12.93, 6.18.35; Linux 7.1. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3389c149c68c3fea61910ad5d34f7bf3bff44e32
- https://git.kernel.org/stable/c/4505f33dab56c274e82f47f94bf60a8cbf8f4b42
- https://git.kernel.org/stable/c/816c6251409db28f1b875988fcbd2ff1764a81f0
- https://git.kernel.org/stable/c/845598b154b9a92e9d279fafafa9405c121ae805
- https://git.kernel.org/stable/c/cbad85b446c06adbc5e5bed565871bb918ce9d32
- https://git.kernel.org/stable/c/f6694bac643c7ae25c0634b63e67d573ed31e5b7
Get alerted when CVE-2026-63962 or the next vulnerability affects your stack