What’s Vulnerable › Vulnerabilities
CVE-2026-63990: bonding: refuse to enslave CAN devices
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-10-08
- Weakness: CWE-476
Description
In the Linux kernel, the following vulnerability has been resolved: bonding: refuse to enslave CAN devices syzbot reported a kernel paging request crash in can_rx_unregister() inside net/can/af_can.c. The crash occurs because a virtual CAN device (vxcan) is being enslaved to a bonding master. During the enslavement process, the bonding driver mutates and modifies the network device states to fit an Ethernet-like aggregation model. However, CAN devices operate on a completely different Layer 2 architecture, relying on the CAN mid-layer private data structure (can_ml_priv) instead of standard Ethernet structures. Since bonding does not initialize or maintain these CAN structures, subsequent operations on the half-enslaved interface (such as closing associated sockets via isotp_release) lead to a null-pointer dereference when accessing the CAN receiver lists. Bonding CAN interfaces is architecturally invalid as CAN lacks MAC addresses, ARP capabilities, and standard Ethernet link-layer mechanisms. While generic loopback devices are blocked globally in net/core/dev.c, virtual CAN devices bypass this check because they do not carry the IFF_LOOPBACK flag, despite acting as local software-loopbacks. Fix this by explicitly blocking network devices of type ARPHRD_CAN from being enslaved at the very beginning of bond_enslave(). This prevents illegal state mutations, eliminates the resulting KASAN crashes, and avoids potential memory leaks from incomplete socket cleanups. As the CAN support has been added a long time after bonding the Fixes-tag points to the introduction of ARPHRD_CAN that would have needed a specific handling in bonding_main.c.
Affected products
- Linux kernel: from 2.6.25 before 5.15.210; from 5.16 before 6.1.176; from 6.2 before 6.6.143; from 6.7 before 6.12.93; from 6.13 before 6.18.35; from 6.19 before 7.0.12 — fixed in 5.15.210, 6.1.176, 6.12.93, 6.18.35, 6.6.143, 7.0.12
How to fix
Upgrade to a fixed version: Linux kernel 5.15.210, 6.1.176, 6.12.93, 6.18.35. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/02f1c87ded33b43d48b4a1d665da15f2157b30d8
- https://git.kernel.org/stable/c/41e8478c4cd896d3abbe33d41afc90c84ac66602
- https://git.kernel.org/stable/c/563090e5d450c665f70d955a39f9587afc7842eb
- https://git.kernel.org/stable/c/69b78b5f3033272e53a2dc2dad675962654a5b38
- https://git.kernel.org/stable/c/8ba68464e4787b6a7ec938826e16124df20fd23d
- https://git.kernel.org/stable/c/9ea8a648d9120f7652bcde1ce2c4ad66871af707
- https://git.kernel.org/stable/c/f4d78a81f57df82e9d82a2c07471fed1a1235893
Get alerted when CVE-2026-63990 or the next vulnerability affects your stack