What’s Vulnerable › Vulnerabilities
CVE-2026-63998: ethtool: module: call ethnl_ops_complete() on module flash errors
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-10-21
Description
In the Linux kernel, the following vulnerability has been resolved: ethtool: module: call ethnl_ops_complete() on module flash errors When validate() fails we are skipping over ethnl_ops_complete() even tho we already called ethnl_ops_begin().
Affected products
- Linux kernel: from 6.11 before 6.18.35; from 6.19 before 7.0.12; 7.1-rc1, 7.1-rc2, 7.1-rc3, 7.1-rc4, 7.1-rc5 — fixed in 6.18.35, 7.0.12
How to fix
Upgrade to a fixed version: Linux kernel 6.18.35, 7.0.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/170d82a57f4be1ce83de823a93bafd218a0d5fb1
- https://git.kernel.org/stable/c/84371fb58423f997939aacdcbc02d128d76a54e5
- https://git.kernel.org/stable/c/d9defbf8b62bde89e206d74c2a2b445b9ed66108
- https://git.kernel.org/stable/c/e96ef1a40dda5b637b1911cd950b11e9848de939
Get alerted when CVE-2026-63998 or the next vulnerability affects your stack