What’s Vulnerable › Vulnerabilities
CVE-2026-64013: ACPI: button: Fix ACPI GPE handler leak during removal
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-10-15
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: ACPI: button: Fix ACPI GPE handler leak during removal Commit a7e23ec17fee ("ACPI: button: Install notifier for system events as well") changed the ACPI notify handler type for ACPI buttons to ACPI_ALL_NOTIFY, but it forgot to update acpi_button_remove() to reflect that change. This leads to leaking the notify handler past driver removal, which may cause a kernel crash to occur if ACPI notify on the given device is triggered after removing the driver, and causes a subsequent probe of the given device with the same driver to fail. Address this by updating the acpi_remove_notify_handler() call in acpi_button_remove() as appropriate.
Affected products
- Linux kernel: from 6.15 before 7.0.12; 7.1-rc1, 7.1-rc2, 7.1-rc3, 7.1-rc4, 7.1-rc5 — fixed in 7.0.12
How to fix
Upgrade to a fixed version: Linux kernel 7.0.12. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/614cb8c26c5aa53196ee9b211b76ee618b147d32
- https://git.kernel.org/stable/c/c85f325d9ec3116b0d4ee9d5b76c26aea0ad5ce0
- https://git.kernel.org/stable/c/fe80251152fed5b185f795ef2cd9f7fe9c3162e0
Get alerted when CVE-2026-64013 or the next vulnerability affects your stack