What’s Vulnerable › Vulnerabilities
CVE-2026-64018: net: mana: validate rx_req_idx to prevent out-of-bounds array access
- Severity: critical (CVSS 9.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-10-19
- Weakness: CWE-129
Description
In the Linux kernel, the following vulnerability has been resolved: net: mana: validate rx_req_idx to prevent out-of-bounds array access In mana_hwc_rx_event_handler(), rx_req_idx is derived from sge->address in DMA-coherent memory. In Confidential VMs (SEV-SNP/TDX), this memory is shared unencrypted and HW can modify WQE contents at any time. No bounds check exists on rx_req_idx, which can lead to an out-of-bounds access into reqs[]. Add bounds check on rx_req_idx in mana_hwc_rx_event_handler() before using it to index the reqs[] array.
Affected products
- Linux kernel: from 5.13 before 5.15.209; from 5.16 before 6.1.175; from 6.2 before 6.6.142; from 6.7 before 6.12.92; from 6.13 before 6.18.34; from 6.19 before 7.0.11 — fixed in 5.15.209, 6.1.175, 6.12.92, 6.18.34, 6.6.142, 7.0.11
How to fix
Upgrade to a fixed version: Linux kernel 5.15.209, 6.1.175, 6.12.92, 6.18.34. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/01f7f893d5e1baae995beeb86cd0f3e6bb2a3b01
- https://git.kernel.org/stable/c/355e9f2b2a7887ca38100127989af3e422ba71d0
- https://git.kernel.org/stable/c/5ddc715324badd7f2641bc177db1d027b402adae
- https://git.kernel.org/stable/c/763a372d344fb12fae566d36ddb46e92454ad58c
- https://git.kernel.org/stable/c/b809d0409991b75a6cff846a5ac27c3062953f84
- https://git.kernel.org/stable/c/fa627a5eaa83fc0261f44ef3769693b886ca6e27
- https://git.kernel.org/stable/c/ff1d5af207bcea857d45fe81505f1bc4b29eaef0
Get alerted when CVE-2026-64018 or the next vulnerability affects your stack