What’s Vulnerable › Vulnerabilities
CVE-2026-64020: nvme-pci: fix dma_vecs leak on p2p memory
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-10-15
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: nvme-pci: fix dma_vecs leak on p2p memory We don't unmap P2P memory, so we don't need to track it. The dma_vec allocation was getting leaked on the completion.
Affected products
- Linux kernel: from 6.17 before 7.0.11; 7.1-rc1, 7.1-rc2, 7.1-rc3, 7.1-rc4 — fixed in 7.0.11
How to fix
Upgrade to a fixed version: Linux kernel 7.0.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/24ea0de233d9ebb5ebd6f6018eaf2084af25e3dd
- https://git.kernel.org/stable/c/85686c72966c5ee637893f124ddb31a1cace7bee
- https://git.kernel.org/stable/c/b9390aa62fdcabdaac2d09545be05901f6cecaf5
Get alerted when CVE-2026-64020 or the next vulnerability affects your stack