What’s Vulnerable › Vulnerabilities
CVE-2026-64023: gpio: aggregator: fix a potential use-after-free
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-10-13
- Weakness: CWE-416
Description
In the Linux kernel, the following vulnerability has been resolved: gpio: aggregator: fix a potential use-after-free On error we free aggr->lookups->dev_id before removing the entry from the lookup table. If a concurrent thread calls gpiod_find() before we remove the entry, it could iterate over the list and call gpiod_match_lookup_table() which unconditionally dereferences dev_id when calling strcmp(). Reverse the order of cleanup.
Affected products
- Linux kernel: from 6.16 before 6.18.34; from 6.19 before 7.0.11; 7.1-rc1, 7.1-rc2, 7.1-rc3, 7.1-rc4 — fixed in 6.18.34, 7.0.11
How to fix
Upgrade to a fixed version: Linux kernel 6.18.34, 7.0.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/30c073cab97afb31901f94de9605177b6b84367e
- https://git.kernel.org/stable/c/7ac4183a41ba048af89eddd82fe8be64619d0871
- https://git.kernel.org/stable/c/ea28b286649b70618e9dd3e895812417a7712a11
Get alerted when CVE-2026-64023 or the next vulnerability affects your stack