What’s Vulnerable › Vulnerabilities
CVE-2026-64041: ASoC: codecs: fs210x: fix possible buffer overflow
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-10-05
- Weakness: CWE-787
Description
In the Linux kernel, the following vulnerability has been resolved: ASoC: codecs: fs210x: fix possible buffer overflow In fs210x_effect_scene_info(), a string was copied like this: strscpy(DST, SRC, strlen(SRC) + 1); A buffer overflow would happen if strlen(SRC) >= sizeof(DST). Actually, strscpy() must be used this way: strscpy(DST, SRC, sizeof(DST)); strscpy(DST, SRC); // defaults to sizeof(DST)
Affected products
- Linux kernel: from 6.18 before 6.18.34; from 6.19 before 7.0.11; 7.1-rc1, 7.1-rc2, 7.1-rc3, 7.1-rc4 — fixed in 6.18.34, 7.0.11
How to fix
Upgrade to a fixed version: Linux kernel 6.18.34, 7.0.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0d435a7ebcd4e97e47673c1ab6fb27f973a053ec
- https://git.kernel.org/stable/c/1ddf678bb75b6383c775ece61d40956c441d8a26
- https://git.kernel.org/stable/c/6daefdf1cd3c56483f61970a76c0ad6028e4118f
Get alerted when CVE-2026-64041 or the next vulnerability affects your stack