What’s Vulnerable › Vulnerabilities
CVE-2026-6409: Denial of Service (DoS) vulnerability exists in the Protobuf PHP library during the parsing of untrusted input
- Severity: high (CVSS 7.1 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-04-16 · updated 2026-10-26
- Weakness: CWE-20
Description
A Denial of Service (DoS) vulnerability exists in the Protobuf PHP library during the parsing of untrusted input. Maliciously structured messages—specifically those containing negative varints or deep recursion—can be used to crash the application, impacting service availability.
Affected products
- Protocol Buffers Protobuf-php (Pecl): before 5.34.0-RC1; before 4.33.6 — fixed in 4.33.6, 5.34.0-RC1
How to fix
Upgrade to a fixed version: Protocol Buffers Protobuf-php (Pecl) 4.33.6, 5.34.0-RC1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-6409 or the next vulnerability affects your stack