What’s Vulnerable › Vulnerabilities
CVE-2026-64111: lsm: hold cred_guard_mutex for lsm_set_self_attr()
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-19 · updated 2026-08-12
Description
In the Linux kernel, the following vulnerability has been resolved: lsm: hold cred_guard_mutex for lsm_set_self_attr() Just as proc_pid_attr_write() already does before calling the LSM hook. This only matters for SELinux and AppArmor which check whether the process is being ptraced and if so, whether to allow the transition.
Affected products
- Linux kernel: from 6.8 before 6.12.92; from 6.13 before 6.18.34; from 6.19 before 7.0.11; 7.1-rc1, 7.1-rc2, 7.1-rc3, 7.1-rc4 — fixed in 6.12.92, 6.18.34, 7.0.11
How to fix
Upgrade to a fixed version: Linux kernel 6.12.92, 6.18.34, 7.0.11. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/4a9b16541ad3faf8bccb398532bf3f8b6bbf1188
- https://git.kernel.org/stable/c/5b906f31e977286888a9e31282589b545b249139
- https://git.kernel.org/stable/c/82d3acee88593e3d9e71cad4b7d6b3cf70de9d07
- https://git.kernel.org/stable/c/a010cadaf5727b8417f62fe9021fcef14a5f9b51
Get alerted when CVE-2026-64111 or the next vulnerability affects your stack